skip to Main Content

E’ accaduto raramente e non siamo mai riusciti a risolvere: provando ad aggiungere un disco al raid viene ritornato un errore di disco in uso. L’abbiamo visto quasi sempre provando la copia da disco, comunque quando collegavamo un terzo disco al NethService.
Le indagini hanno portato ad incolpare con ragionevole certezza dmraid, ma non siamo comunque riusciti ad impedirgli di prendersi il disco in fase di boot. Quando ho provato a creare un initrd senza dmraid il sistema non si è avviato e comunque in caso di boot da cd è impossibile modificare initrd.
Ho un paio di strade da provare, quindi se dovesse accadere nuovamente vorrei essere avvisato.
In sostanza, credo che i dischi che sono stati usati con un raid hardware di tipo software come quello dei bios dei vari ICHnR, siano marcati in qualche modo e vengano presi automaticamente in carico da dmraid. La prova dovrebbe essere questa:

# dmraid -r
/dev/sda: ddf1, ".ddf1_disks", GROUP, ok, 488019106 sectors, data@ 0
/dev/sdb: ddf1, ".ddf1_disks", GROUP, ok, 488019106 sectors, data@ 0

Questi dischi sono stati inizializzati dal bios del raid di un ICH9R di un HP ML110G5. Prima dell’inizializzazione, dmraid diceva “No RAID disks”. L’idea numero 1 sarebbe quindi di usare “dmraid -rE” per de-inizializzare il disco, in modo che dmraid non lo prenda in carico automaticamente.
In caso di boot da cd, idea numero 2, si dovrebbe digitare “sme nodmraid” per non attivare il dmraid, ma potrebbe sempre essere possibile usare “dmraid -rE”.

Filippo Carletti

Da programmatore di videogiochi a sistemista Linux: maniaco dell’ottimizzazione, sempre a basso livello. Ogni problema è una nuova sfida.

Back To Top
English French German Italian Spanish