Problema che mi è capitato di affrontare in un paio di occasioni con l’aiuto di Filippo e Giacomo: con la nuova versione di samba i wide links sono disabilitati di default per questioni di sicurezza, quindi un symlink che collega path diversi (per esempio da una ibay ad un’altra) genera un errore a causa di mancanza di permessi. Per ripristinare la funzionalità è necessario un template-custom per la configurazione di smb.conf:
mkdir -p /etc/e-smith/templates-custom/etc/smb.conf/
echo "wide links = yes" >/etc/e-smith/templates-custom/etc/smb.conf/11widelinks
Una volta creato il template, basta un
signal-event ibay-modify-servers
per attivare la modifica.


